Ovid & Safari: Do They Get Along?

Do + = ?

Not necessarily. The official word from Ovid is:

“While Safari normally works with Ovid it is not supported. We do not test our application against the Safari browser and don’t guarantee that it will work.”

And their view on browser requirements can be seen at OvidSP Configuration

We have tested Apple’s Safari browser with Ovid and had success. Others have had problems crop up (like not being able to view beyond the first page of search results). Some of this could be related to the version of Safari used, remote access, etc. There are several variables. Probably, the best approach is to use Firefox if possible and if not, then use the latest version of Safari. And as always, contact lib-ejhelp@interchange.ubc.ca if you have any questions or problems with UBC’s eResources.

This entry was posted in Browsers, Databases and tagged , , . Bookmark the permalink.