EbscoHost Databases No Longer Support Internet Explorer 6

If you are clinging to a retro version of IE, time to move on.

EbscoHost databases (and we subscribe to a lot) now require Internet Explorer 7 or later. You can download the latest version (Internet Explorer 8) for free HERE.

This entry was posted in Browsers, Databases, Platform News and tagged , . Bookmark the permalink.